Citrix PDF Printer does not open full screen with Edge as default PDF viewer

Citrix PDF Printer does not open full screen with Edge as default PDF viewer

book

Article ID: CTX478158

calendar_today

Updated On:

Description

When users are using the HTML5 client and Citrix PDF Printer while using Edge as the default PDF viewer the print job is shown but there is a scroll bar on the right. If the user changes to Adobe as the default PDF viewer the print job displays correctly.

Resolution

  1. Only seen when Citrix Receiver for HTML Client is being used and policy has been enabled for Citrix PDF Printer ( HTML Version ).
  2. Exclude the Edge2View Process
  3. Registry key is:
Key: HKLM\SYSTEM\CurrentControlSet\services\CtxUvi 
Value Name: UviProcessExcludes 
Type: REG_SZ 
Value: msedgewebview2
  1. Once the change has been added or new registry is created, users need to restart the VDA for the changes to be applied.

Problem Cause

  • When using Citrix PDF Printer to generate a PDF file, the content doesn't open in a full Screen window.
  • Instead it opens in 1/4th of the Window with a scroll option at the right.
  • This behaviour is seen in Edge but works fine in Chrome.
  • Behaviour is after the PDF file has been created using Citrix PDF Printer

Additional Information

https://www.citrix.com/blogs/2018/06/05/enhanced-printing-experience-with-citrix-receiver-for-html5/
-But still since Edge is a Chromium browser, it should work as expected in Edge browser.

https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/policies/reference/ica-policy-settings/printing-policy-settings/client-printers-policy-settings.html ​​​​​​​