EPA Scan failure on MacOS with error message "Error during unzipping libraries"

EPA Scan failure on MacOS with error message "Error during unzipping libraries"

book

Article ID: CTX477627

calendar_today

Updated On:

Description

EPA scan failed on MacOS client with following errors in "~/Library/Application Support/Citrix/EPAPlugin/*" logs:

Error during unzipping libraries
{
NSAppleScriptErrorAppName = CitrixEndpointAnalysis;
NSAppleScriptErrorBriefMessage = "unzip: cannot find or open 1/Library/Application Support/Citrix/libs, 1/Library/Application Support/Citrix/libs.zip or 1/Library/Application Support/Citrix/libs.ZIP."; NSAppleScriptErrorMessage = "unzip: cannot find or open 1/Library/Application Support/Citrix/libs, 1/Library/Application Support/Citrix/libs.zip or 1/Library/Application Support/Citrix/libs.ZIP.";
NSAppleScriptErrorNumber = 9;
NSAppleScriptErrorRange = "NSRange: {0, 154}";
}

Resolution

Please extract "MacLibs" folder and contains files manually from Maclibs.zip in NetScaler upgrade firmware package and copy them to MacOS path "~/Library/Application Support/Citrix/libs" and "~/Library/Application Support/Citrix/MacLibs" folders

Click here to download NetScaler Firmware.
 

Problem Cause

Maclibs.zip file extract failure on defected MacOS Client.