Citrix UPS Network printers missing in the Unified Print Dialog

Citrix UPS Network printers missing in the Unified Print Dialog

book

Article ID: CTX477514

calendar_today

Updated On:

Description

In a Citrix session running on a Windows 11 22H2 Virtual Delivery Agent, the user might not see Universal Print Server (UPS) network printers in the unified print dialog that is displayed by Notepad and Wordpad. 

Certain applications, such as Adobe Reader, Microsoft Word, and Microsoft Excel, that do not use the unified print dialog are not affected by this issue.


 

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

The following is a manual workaround for this third-party issue.

Run this command on the VDA as administrator:

reg add "HKCU\Software\Microsoft\Print\UnifiedPrintDialog" /v "PreferLegacyPrintDialog" /d 1 /t REG_DWORD /f

Alternatively, run the registry editor as administrator and manually, create a “PreferLegacyPrintDialog” DWORD registry value equal to 1 under the "HKCU\Software\Microsoft\Print\UnifiedPrintDialog" registry key path.


 

Problem Cause

This is a third-party issue(OS-specific) in Windows 11 22H2

Issue/Introduction

Citrix UPS Network printers missing in the Unified Print Dialog