Cannot complete your request on Gateway URL after adding new domain to trusted domains
book
Article ID: CTX473046
calendar_today
Updated On:
Description
After adding a trusted domain to Storefront. when you go to "Manage Authentication Methods", click on the settings, click on "Configure trusted Domains" and add new domains, when users try to go to the gateway URL, you may get either "Login Expired" or "Cannot Complete your Request|" error messages.


Resolution
Once a new domain is added to trusted domain, default settings are restored for the receiver for web settings.
Previously pass-through authentication for Citrix Gateway was unchecked.
After a new domain was added, this setting was checked again as it went back to the default.
You will need to manually uncheck that option and propagate changes to all remaining storefront servers if you have a server group.
Once this was done, issue was resolved.
Problem Cause
Settings for receiver for web were returned to default.
Issue/Introduction
After adding a trusted domain to Storefront. when you go to "Manage Authentication Methods", click on the settings, click on "Configure trusted Domains" and add new domains, when users try to go to the gateway URL, you may get either "Login Expired" or "Cannot Complete your Request|" error messages.
Was this article helpful?
thumb_up
Yes
thumb_down
No