[NetScaler] Black Screen in launching ICA when enabling HDX Insight

[NetScaler] Black Screen in launching ICA when enabling HDX Insight

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Article ID: CTX472919

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Updated On:

Description

Launching ICA through Citrix Gateway with HDX Insight enabled, you may see black screen issue randomly for about 30~40 seconds in the beginning of desktop view on Citrix Workspace App. 

Environment

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Resolution

1. The issue can be avoided with below workaround. The impact for this command is that client side L7 latency (between NetScaler and clients) and server side L7 latency (between NetScaler and VDAs) will not be visible in ADM. However, ICA RTT(between clients and VDAs) is still available. 
> shell
root@ns# nsapimgr -ys enable_ica_l7_latency=0

To rollback the configuration, you can use below command.
> shell
root@ns# nsapimgr -ys enable_ica_l7_latency=1

To check the current value of the parameter, you can use below command.
> shell
root@ns# nsapimgr -d allvariables | grep enable_ica_l7_latency
enable_ica_l7_latency:  1 =>current value

2. To make the command persists after reboot, you have to add the command in /nsconfig/rc.netscaler. If /nsconfig/rc.netscaler doesn't exist, you have to create one manually.

 

Problem Cause

After enabling HDX insight, it is possible that VDA doesn't receive the bandwidth estimate packets from the client for some seconds. It causes that VDA sends data with slow speed, which further causes the black screen issue.