Error code 1603 received when trying to upgrade Storefront

Error code 1603 received when trying to upgrade Storefront

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Article ID: CTX472900

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Updated On:

Description

An error displays during Storefront upgrade  "\CitrixStoreFront-x64.msi failed with error code 1603"

Resolution

  1. Check the local users and groups on the server to ensure they have a description.
  2. If no description is listed, add a description (i.e. Users, groups and machines who are allowed to use Citrix Replication Service) 
    • The issue should now be resolved.

Problem Cause

Installation logs shows the following error:

Calling data.LoadGroups
VersionData:Load Failed due to exception: System.IndexOutOfRangeException: Index was outside the bounds of the array.
   at Citrix.DeliveryServices.InstallController.Configuration.VersionData.LoadGroups()
   at Citrix.DeliveryServices.InstallController.Configuration.VersionData.Load(String backupPath, Version version, Action`1 traceInfo)
VersionData:Load finishes.
 Invalid version will be ignored: 'C:\ProgramData\Citrix\Storefront Install\3.22.3000.9' Exception: System.IndexOutOfRangeException: Index was outside the bounds of the array.
  at Citrix.DeliveryServices.InstallController.Configuration.VersionData.LoadGroups()
   at Citrix.DeliveryServices.InstallController.Configuration.VersionData.Load(String backupPath, Version version, Action`1 traceInfo)
   at Citrix.DeliveryServices.InstallController.ConfigurationController.LoadConfiguration()
 

This error could be seen if the description for any Citrix*** in local groups were missing on the SF server.