Unable to connect to Storefront using Workspace App

Unable to connect to Storefront using Workspace App

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Article ID: CTX463891

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Updated On:

Description

Adding store fails with error 'cannot contact store'
We can access store via CWA  for web

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Removed folder from previous CWA install found under 'C:\Program Files (x86)\Citrix\AuthManager'

Or create registry key below and restart CWA
 
Type: string
Name: TrustAllModules

Value: True
Location: HKLM\SOFTWARE\WOW6432Node\Citrix\AuthManager\

Problem Cause

During launch CWA will load a number of executables - as part of this process it validates that these executables are being launched from the expected location by reviewing the path stored in the registry.
In this case CWA attempts to load Authmansvr on client from 'C:\Program Files (x86)\Citrix\AuthManager' - this path is from a version prior to Receiver 4.12
CWA checks the value 'AuthManSvrPath' under HKLM\Software\wow6432node\citrix\authmanager which points to 'C:\Program Files (x86)\Citrix\ICA Client\AuthManager\AuthManSvr.exe'' - this has been the case since CWA 1912
 
As a result CWA flags AuthManSvr.exe as untrusted and fails to load it. This causes store add to fail