PVS PXE boot fails: No more network devices / No bootable device

PVS PXE boot fails: No more network devices / No bootable device

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Article ID: CTX463850

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Description

  • PXE boot fails TFTP transfer after receiving a valid DHCP configuration.  Sample failure of this type in screenshot below.
  • Network traces show correct ARP responses going both ways. 
    • The target device will not send the first read request unless the ARP response is correct. (line 13 in the screenshot).
    • After receiving the TFTP request (line 14), the PVS server does a similar query (line 15) and will not send the TFTP response unless the ARP response is correct (line 16).  In the screenshot below, the response in line 16 indicates that the target device is healthy.
  • Post-DHCP-ARP.PNG
  • Network traces shows the TFTP request going to the PVS server.  The trace might might show an ICMP response type 3 / Code 3 response. 
ICMP type 3.PNGConsole of failed boot with failed TFTP.
no more network devices.PNG

Resolution

The ICMP reply indicates there is network connectivity, but not at port 69. Below are steps that can be used to discover a possible cause.
  1. The Citrix PXEChecker utility BIOS test can provide helpful feedback. 
  2. Enable logging for TFTP and inspect the Application event log for events logged by BNTFTP.  Use the TFTP Control Panel: 
    1. To open the TFTP Control panel, launch "C:\Program Files\Citrix\Provisioning Services\TFTPCPL.CPL" with elevated privilege.
    2. Select the TFTP Logging tab and move the slider to "Log All Events". 
    3. Restart the StreamProcess service. Attempt to boot a target device. 
    4. Filter Application log events for the BNTFTP provider.
    5. After the test, return the TFTP Logging back to normal and restart the StreamProcess.
  3. While you are in the TFTP control panel, inspect TFTP Network.  Only one interface can service TFTP requests.  Make sure the interface selected has the correct port (usually 69), and that the interface is the same one in DHCP Option 66. 
  4. If DHCP Option 66 has a hostname instead of an IP address, verify that DNS has only one IP address for the host name and that this ip address is the same as DHCP Option 66.
  5. Verify PVS Server windows firewall is allowing traffic over 69.
  6. Consider any third party application on the PVS server blocking port 69.
  7. Consider a security device, like IDS/IPS.
  8. Carefully document the DHCP scopes, Gateways, Addresses for Distribution. If there is more than one DHCP server, make sure that there are no overlapping DHCP scopes and the DHCP Option 66 is correct for every subnet

Problem Cause

The network connection is open, but Port 69 in the direction PVS Server >> Target Device is blocked.