Grey or Black Screen on launching the VDAs upgraded from 7.15 LTSR to 1912 LTSR or Newer versions
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Article ID: CTX463724
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Updated On:
Description
• Grey or Black Screen may appear when launching Windows VDAs which were Upgraded from XenDesktop XA/XD 7.15 LTSR to CVAD 1912 LTSR
• Grey Screen could appear intermittently or only for External Connections which pass via the Internet over Netscaler or other 3rd Party Firewall/Gateway
• Citrix Director/Cloud Monitor Tab would show the Protocol as UDP instead of TCP for affected sessions
Resolution
Solution 1:
Look for HDX Adaptive Transport setting in Citrix policy and explicitly configure it with the value ‘Off’
Solution 2:
If MTU Discovery is enabled in ICA file, upgrade to Workspace app for Windows 2105 or later or Workspace app for Windows 1912 CU4 or later [Latest Citrix Workspace App Versions are recommended]
Note: It is possible to disable the HDX Enlightened Data Transport policy on a per client basis even if the policy is enabled in Citrix Studio. This can be accomplished by adding the “receiver.adml” template to the client machine and changing the GPO setting at Computer Configuration > Administrative Templates > Citrix Receiver > Network > Routing > Transport Protocol for Receiver to: Enabled (EDT first with fallback to TCP) or Off (TCP).
Problem Cause
Although Adaptive Transport is recommended for flexibility and performance purposes, some complex network environments could restrict the use of UDP or have SSL/TLS inspection which may cause undesired results. Please ensure to check with your networking team to avoid issues.
Additional Information
https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/1912-ltsr/technical-overview/hdx/adaptive-transport.html
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