book
                        
Article ID: CTX463514
                        
                    
                    
                        calendar_today
                        
Updated On: 
                    
                 
                
                    
                
                    
                    
                        
                            
Description
                        
                        
                            Catalog fails to update
Catalog has an exclamation mark alert with a "Desktop Studio closed" message

 
                         
                     
                    
                    
                    
                    
                        
                            
                                
Resolution
                            
                            
                                Use 
Remote PowerShell SDK to execute the below cmdlets: 
- In Remote SDK, run:
	
asnp citrix*
Get-XdAuthentication
Get-BrokerCatalog -Name <Your catalog name here>
	 - Take note of the "TaskState_..." entry under the MetadataMap parameter:
 
- Stop that task by running:
 
Set-BrokerCatalogMetadata -CatalogID <ID of your catalog> -Name TaskState_a9a55b08-cdb3-426b-a39d-d9da6713f2a9 -Value Completed
- The alert should disappear, and you can re-try your catalog update.
 
Problem Cause
Issue might be caused by an error during an update.