ICA session freezes 8-10 minutes after session launch

ICA session freezes 8-10 minutes after session launch

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Article ID: CTX462384

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Updated On:

Description

ICA session freezes 8-10 minutes after session launch.
The session remains active, only the display is frozen, for example keyboard typing will continue through to session.
Users can successfully reconnect to the session and work again for similar time before the session again appears frozen.
 

Environment

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Resolution

Resolution 1:

  1. Remove non-existent or non responsive network printer from client devices.



Resolution 2:

  1. Increase timeouts on client device to accommodate non-existent, non responsive network printers:
  2. Apply the following configuration on the affected en, reboot and verify if issue remains:
[Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\ICA Client\Engine\Configuration\Advanced\Modules\WFClient]
"MaximumVCWorkItems"="60"
"MaximumWDInputBuffers"="30"




Resolution 3:

  1. Apply policy "Autocreate local (non-network) printers only" to prevent client network printer mapping into ICA sessions.

Problem Cause

Non-existent or non responsive network printers on client devices

Issue/Introduction

Windows CWA, ICA session freezes 8-10 minutes after session launch, the client machine has non-existent or non responsive network printers