Secure Mail Issues with Android Push Notifications

Secure Mail Issues with Android Push Notifications

book

Article ID: CTX461561

calendar_today

Updated On:

Description

SecureMail on android devices was not getting background push notifications, therefore users had to manually open SecureMail to check for email.

When examining network traces from the ADC, we observe connections to certain Google owned IP addresses are being blocked.

Resolution

The issue was resolved by opening additional targets in their firewall as follows:
  • *.googleapis.com
  • *.apis.google.com 
Note - these hosts must be open for connections not just from the Exchange Web Server IP Addresses, but also from the ADC and from the mobile devices on the internal WiFi

Problem Cause

EWS notifications to SecureMail were blocked due to firewall restrictions.

Additional Information

Citrix Documentation pages  on SecureMail / Citrix Endpoint Management ports requirements
Google documentation pages on FCM  Related support article: