CVAD on cloud: copy paste is not working - Citrix Clipboard service missing in services console

CVAD on cloud: copy paste is not working - Citrix Clipboard service missing in services console

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Article ID: CTX461457

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Updated On:

Description

CVAD on cloud: copy paste is not working inside the ICA Session

Resolution

  1. Export the following registry key from a working server and import on the non-working server.
    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CtxClipboardSvc
  2. Reboot the server and the Citrix Clipboard service should now be present and in a running state. 

Problem Cause

Citrix Clipboard service related registry key was missing in the registry.

Additional Information

Note: In this specific case Applayering was used and the service was missing in the platform layer. So the changes were made in platform layer, finalized the layer, republished the image and then updated the MCS catalog with the revised image.