PVS : Failed to connect to the PVS API, error : Unable to connect to the remote server
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Article ID: CTX461284
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Description
PVS : Unable to connect to the PVS API, error - Unable to connect to the remote server
Resolution
1. Create a self-signed certificate and import it to trusted root authority.
New-SelfSignedCertificate -Type SSLServerAuthentication -Container PVSSoap -Subject "CN=PVS-01.fqdn" -CertStoreLocation "Cert:\LocalMachine\My" -KeyExportPolicy Exportable
2. Re-run the configuration wizard and highlight the root certificate.
3. Import the Provisioning module :
Import-Module "C:\Program Files\Citrix\Provisioning Services\Citrix.ProvisioningServices.dll"
4. Ping the Citrix Provisioning API service:
Get-PvsApiServiceStatus -PvsServerAddress <FQDN of PVS Server> -PvsServerPort 54324
Problem Cause
1. Correct root certificate may not have been imported.
2. Incorrect port number may have been used.
Additional Information
https://docs.citrix.com/en-us/provisioning/current-release/troubleshooting/api.html
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