Basic steps to take for troubleshooting slow performance of Citrix Studio

Basic steps to take for troubleshooting slow performance of Citrix Studio

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Article ID: CTX460185

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Updated On:

Description

Extremely slow performance is exhibited in Studio on DDC server,  e.g. when clicking a machine catalog it may need up to 5mins before the catalog content is fully shown.

Environment

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Resolution

  • Shutdown one of the DDC and check whether the problem is related to the target DDC
  • Check the SQL transaction log space for Site/Monitor/Log DB to confirm whether it is nearly full. 
  • Use Powershell listed in CTX238581 and check if the command execution is slow. 
  • If the issue only happens on Studio, then try to clear the MMC cache for Studio: 
Clean the MMC Cache
  1. Open a new instance of the Microsoft Management Console (MMC) (Start -> Run… ->mmc -> OK) and go to File -> Options -> Disk Cleanup.
  2. Click on Delete Files to delete MMC cache files and per-user preferences for console files which are saved in the user’s profile.
or Clear them in Studio: Files -->Options -->Disk Cleanup

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  • If all these cannot help, try to enlarge the CPU/Memory hardware resource of each DDC and DB, then restart them. 

Problem Cause

  • Connection between DDC and DB is unstable, or transaction log is full for Citrix databases.
  • Caused by DDC mmc cache loading issue
  • VM performance is degraded.

Additional Information

https://support.citrix.com/article/CTX224429
https://support.citrix.com/article/CTX232943