Error "Try again after some time or contact your help desk" after authentication passed

Error "Try again after some time or contact your help desk" after authentication passed

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Article ID: CTX460180

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Updated On:

Description

After inputting your username and password to "https://x.x.x.x/manageotp" page, you are encountering an error message that says, "Try again after some time or contact your help desk"

"Rejecting with error code 4009“,”receive_ldap_user_search_event:ldap_first_entry_returned null, user XXX not found“ could be found via NetScaler aaad.debug module .
In brief, the error message "Rejecting with error code 4009" indicates that a user with the identifier "XXX" was not found during an LDAP user search, leading to the rejection of the authentication attempt.

Environment

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Resolution

Set  "Server Logon Name Attribute"  in LDAP Sever "LDAP_OTP_set_no_auth" to "sAMAccountName"
 

Problem Cause

"Server Logon Name Attribute"  in LDAP Sever "LDAP_OTP_set_no_auth" was incorrectly set to "sAMAccount" instead of "sAMAccountName"

Additional Information

NetScaler Gateway OTP Setup Guide from Carlstalhood