RDP session fails to open, black screen appears briefly and the connection stops
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Article ID: CTX460134
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Updated On:
Description
- Cannot start RDP session on VDA. A black screen appears briefly and the connection stops.
Environment
Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.
Resolution
Trace analysis shows the failure was caused by the unexpected access to an existing session entry (HKLM\SOFTWARE\Citrix\Ica\Session\Session_ID) with the same session ID as the RDP session.
The session entries in this key correspond to HDX sessions that are no longer active.
To resolve the issue remove all session IDs for sessions that are no longer active.

Problem Cause
Stale info in the registry.
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