"Cannot complete request" when user changes the expired password on the first attempt

"Cannot complete request" when user changes the expired password on the first attempt

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Article ID: CTX460029

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Updated On:

Description

"Cannot complete request" error occurs when user changes the expired password on storefront logon page.
Check the event log on storefront, there is one error:
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Resolution

1. Go to c:\inetpub\wwwroot\citrix\*StoreName*Auth\
2. Backup web.config
3. Open web.config
4. Find the line
5. Increased the clientOpenTimeout and clientSendTimeout values to 10 minutes.
6. Save the file
7. Do an IISReset so the new configuration is picked up

Problem Cause

Password change request is getting timed out after one minute, which is the default timeout value setting if Storefront doesn't get the response from domain controllers for the change password request.