Users unable to launch - Error: "Cannot complete your request"

Users unable to launch - Error: "Cannot complete your request"

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Article ID: CTX460002

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Updated On:

Description

'Cannot complete your request' while trying to access the Web Store URL. StoreFront events show that a loopback communication failed.

Resolution

  1. Check the StoreFront event if the loopback URL is on HTTP or HTTPS.
  2. Check the bindings in IIS for 'Default Web Site', if the required HTTP/HTTPS binding is configured.
  3. In the StoreFront Console, go to Manage Receiver for Web Sites > Configure > Advanced Settings and check the 'Enable loopback communication' setting.
    • If the Store URL is HTTPS and the setting should be ideally 'On' which forces loopback communications to go on HTTPS.
    • If the setting is 'OnUsingHttp', loopback communications will happen over HTTP.
  4. The setting can be changed to use HTTP or HTTPS to check if the issue gets resolved.

Problem Cause

HTTP (TCP 80) binding missing in IIS, while loopback communication was set to 'OnUsingHttp'.