User cannot launch ICA session with "Remote Desktop Services Is Currently Busy" error
book
Article ID: CTX459728
calendar_today
Updated On:
Description
User cannot launch ICA session with "Remote Desktop Services Is Currently Busy" error.
The same issue persists even user directly login via RDP or console.
At the same time, there are many ghost sessions in "disconnected" status remaining on Server VDA
Resolution
We can create below registry for the session leak issue:
- Under "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Kernel"
create a SeTokenDoesNotTrackSessionObject value (it should be a reg REG_DWORD value) and set to 1
- Reboot the server and check if the ghost session issue will be gone.
Problem Cause
Remote Desktop Service currently hang and it cannot re-start as expected
Was this article helpful?
thumb_up
Yes
thumb_down
No