NetScaler NTP sync failure when NTP server Root Dispersion value greater that 1 second

NetScaler NTP sync failure when NTP server Root Dispersion value greater that 1 second

book

Article ID: CTX457057

calendar_today

Updated On:

Description

NetScaler NTP sync failure when Root Dispersion value is larger than 1 second.

Dispersion is the maximum difference recorded between the NTP client and the NTP server (recorded in seconds). Root Dispersion measures the maximum amount of variance between the NTP server and its known time source. If either of these values is too high, the time source will not be trusted.

image.png

Resolution

  1. Correct NTP server configuration to reduce root dispersion and make sure the offset is within 1 seconds.
  2. Then enable ntp sync in NetScaler with below CLI
enable ntp sync
e.g., If NTP server is a windows server, you could decrease the LocaClockDispersion value follow below configuration:


Important: Please consult with the Windows certified engineer before making changes to the Windows configuration. Citrix will not take responsibility for any unexpected outcome. 
 
  1. Navigate to Windows registry key
    • Local Group Policy Editor > Computer Configuration > Administrative Templates > System > Windows Time Service > Global Configuration Settings
  2. Set LocalClockDispersion value to 0.
  3. Restart the W32time service on Windows with the following command:
net stop w32time
net start w32time

Problem Cause

  • This is by product design. If the NTP server message claimed its' root dispersion is too high, the NTP client shouldn't accept NTP messages from the server.
  • In NetScaler, it will discard NTP server's message if NTP server's Root Dispersion value greater that 1 second.