Citrix ConfigSync Service Error 505 Failed An Import " No Items match supplied pattern "

Citrix ConfigSync Service Error 505 Failed An Import " No Items match supplied pattern "

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Article ID: CTX399385

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Updated On:

Description

The below error was getting logged on the new controller post DB migration to a new server.

Citrix ConfigSync Service error 505 failed an import " No Items match supplied pattern "
 

Resolution


Followed the article https://docs.citrix.com/en-us/citrix-virtual-apps-desktops-service/manage-deployment/local-host-cache.html#troubleshoot  to enable tracing for the LHC and from the CitrixBrokerConfigSyncReport.html report found that the import was failing on a tag that had a space at the end of the name.

Removing the problem tag fixed the issue.

Problem Cause

From the CDF traces it was found that the Config sync errors were pointing to the below failure while adding tag.

 "Error was encountered while importing the Broker Service config while attempting , "Add-BrokerTag"



Detailed Analysis 
  • The configsync service received an updated configuration from the Broker Service and the Configuration Service

Record 503 event: ConfigSync.ps1 received an updated configuration from the Broker Service and the Configuration Service",""

HaImportDatabase database was created.

  • Import script was excited and config was successfully imported.

New import script zip path: C:\Windows\SERVIC~2\NETWOR~1\AppData\Local\Temp\498bc658-357a-4f6d-b9c1-af35b8aafdb8.zip

Successfully imported the new Central Config Service configuration

  • Error was encountered while importing the Broker Service config while attempting , "Add-BrokerTag"

Import Script: starting import of Broker Service config",""

ConfigSync.ps1 output: Import Script: Exception: Add-BrokerTag: No items match the supplied pattern

Exception Position: Logging.ps1:199",""

ConfigSync.ps1 output: 20:24:43: Record 505 event: No items match the supplied pattern",""

  • Before aborting the import HaImportDatabase was deleted.

Additional Information

https://docs.citrix.com/en-us/citrix-virtual-apps-desktops-service/manage-deployment/local-host-cache.html#troubleshoot