RDP Error from ICA Session: "An authentication error has occurred (Code: 0x800706be)"

RDP Error from ICA Session: "An authentication error has occurred (Code: 0x800706be)"

book

Article ID: CTX399358

calendar_today

Updated On:

Description

When we try to RDP inside an ICA session we get below error :

Faulting application name: CredentialUIBroker.exe, version: 10.0.14393.4169, time stamp: 0x5ff78e7f
Faulting module name: CtxWinlogonProv.dll, version: 0.0.0.0, time stamp: 0x5faeeb2d
Exception code: 0xc0000005
Fault offset: 0x000000000000eb42
Faulting process id: 0x2b70
Faulting application start time: 0x01d729e10cd6ab55
Faulting application path: C:\Windows\System32\CredentialUIBroker.exe
Faulting module path: C:\Program Files (x86)\Citrix\System32\CtxWinlogonProv.dll

Resolution

Open users/groups by going into computer management console and update groups as below:
  • Action – Update – Group – Remote Desktop Users – Add Members “DOMAIN\Domain Users”
  • Action – Update – Group – Remote Desktop Users – Add Members “NT AUTHORITY\Authenticated Users”
  • Action – Update – Group – Performance Log Users – Add Members “NT Service\CitrixTelemetryService”
  • Action – Update – Group – Performance Monitor Users – Add Members “NT Service\BrokerAgent”
  • Action – Update – Group – Administrators – Add Members DOMAIN\Your_Citrix_Admins_Group

Problem Cause

The outlined permissions required are missing causing credentials to get declined