Unable to upgrade the Storefront from 7.15 LTSR CU7 to CU8; fails with "An error occurred during installation. Please ensure all the required prerequisites have been installed and run the installer again."

Unable to upgrade the Storefront from 7.15 LTSR CU7 to CU8; fails with "An error occurred during installation. Please ensure all the required prerequisites have been installed and run the installer again."

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Article ID: CTX381143

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Updated On:

Description

Unable to upgrade the SF from 7.15 LTSR CU7 to CU8; fails with "An error occurred during installation. Please ensure all the required prerequisites have been installed and run the installer again."

Resolution

  1. Navigate to C:\programdata
  2. Right click  on "Citrix" Folder. Go to Security tab. 
  3. Click ok on prompt “ The permission on Citrix are incorrectly Ordered, which may cause some entries to be ineffective” 
  4. Click Ok to close the Folder properties.

Problem Cause

NTFS Permission issues, causing Error: "This access control list is not in canonical form and therefore cannot be modified." upon Storefront upgrade

Issue/Introduction

Reference case - 80901378