Citrix FAS: Your session 'AppName' did not launch successfully due to error code 3500

Citrix FAS: Your session 'AppName' did not launch successfully due to error code 3500

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Article ID: CTX340181

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Updated On:

Description

Session launch fails in the double hop scenario as explained below,

First Hop: Successful desktop Launch 
Second Hop: Session fails to launch with the error code “Your session 'AppName' did not launch successfully due to error code 3500. Please contact your administrator for more information about the error.”

The second hop launch fails only when the FAS is used, the launch is successful if the User name and Password are used for authentication.

Resolution

Whitelist the ports between the Storefront and the FAS server as per https://docs.citrix.com/en-us/tech-zone/build/tech-papers/citrix-communication-ports.html#federated-authentication-service

Problem Cause

Network port blockage between the components would cause such issues.