Citrix Workspace App - Fresh install/Update operation of CWA App may result in delay for about 10 - 30 mins

Citrix Workspace App - Fresh install/Update operation of CWA App may result in delay for about 10 - 30 mins

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Article ID: CTX335639

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Updated On:

Description

CWA Windows app installer gets stuck/hung for an extended time during installation/Updation and eventually succeeds(Typically after 10 - 30mins).

Users might experience delays in the installer/upgrade workflow.

Resolution

  • Navigate to C:\Program Files (x86)\Microsoft\EdgeWebView\Application" folder and Delete empty directories under the Application folder.
           OR
  • If you have EdgeCore, EdgeBeta, please navigate under those folders and delete them as well. i.e., delete empty folders under
    • C:\Program Files (x86)\Microsoft\Edge Beta\Application"
    • C:\Program Files (x86)\Microsoft\EdgeCore\Application"

Problem Cause

A bug has been identified in the Microsoft EdgeWeb View installer.

Details - The Edge WebView2 setup cleanup routine fails to remove previous version directories in Program Files X86\Microsoft\EdgeWebView\Application if the previous version directories do not contain the file msedgewebview2.exe.

This is interrupting the Citrix install/Update workflow and causing a time out of 10mins before proceeding to the next installation.

Additional Information