Citrix IME might not be set as active IME automatically while using Local IME in Chinese, Japanese, or Korean

Citrix IME might not be set as active IME automatically while using Local IME in Chinese, Japanese, or Korean

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Article ID: CTX330830

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Updated On:

Description

Citrix IME might not be set as active IME automatically at the VDA side while using Local IME in Chinese, Japanese, or Korean.
For example, when users enable the keyboard layout options of dynamic sync and Local IME and start a VDA session with Japanese IME, the IME at the VDA side should be switched to Citrix IME automatically.

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However, when the issue occurs, Microsoft IME would be set instead:

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Resolution

There are two ways to solve the issue:
  1. Users can change the client keyboard layout to English and then back to Chinese/Japanese/Korean IME.
  2. Users can also select Citrix IME manually in the remote language bar.

Problem Cause

This is caused by the 3rd party API limitation for switching current IME to Citrix IME.