"Failed to convert Boot Configuration Data. The system cannot find the file specified. (0x00000002)"

"Failed to convert Boot Configuration Data. The system cannot find the file specified. (0x00000002)"

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Article ID: CTX327968

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Description

  • Attemtpting to run P2pvs and get error "Failed to convert Boot Configuration Data. The system cannot find the file specified. (0x00000002)"
  • Followed https://support.citrix.com/article/CTX202159 and still same issue.  =========================================================================================
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Resolution

  1. Boot target into Private mode. Make sure no additional HD is attached.
  2. Open cmd as admin run cmd:
unload HKLM\BCD00000000
  1. Next, copy Boot mgr from system drive L:\ to C:\. Run a robocopy (Robocopy L:\ C:\ bootmgr)
  2. Copy boot folders from system drive L:\ to C:\ (robocopy e:\boot c:\boot /s)
  3. Make C:\ as partition. Run below commands to achieve that.
Bcdedit /store c:\boot\bcd /set {bootmgr} device partition=c:
Bcdedit /store c:\boot\bcd /set {memdiag} device partition=c:
 
  1. Go back to diskmgmt.msc, then remove the L:  letter, it will make sure follow prompt.
  2. Make C:\ as active partition. right click ad make partition as active on diskmgmt.msc.
  3. After booting delete the L:\ drive letter and reboot target. 
  4. Run P2PVS using CTX202159 perform Volume to volume and follow onscreen instructions to complete successfully.

Problem Cause

Corruption of BOOTMGR file

Additional Information

https://support.citrix.com/article/CTX202159