While trying to gather logs the file shows "Could not process the file. File size is too large".

While trying to gather logs the file shows "Could not process the file. File size is too large".

book

Article ID: CTX324867

calendar_today

Updated On:

Description

- While trying to reach the logs via the ADC GUI it says "Could not process the file. File size is too large "
- The file is not that large (less than 1-5 MB) and can be observed via CLI or extracted via SFTP. 
- Only fails via GUI

 

Environment

The above mentioned sample code is provided to you as is with no representations, warranties or conditions of any kind. You may use, modify and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that (a) the sample code may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the sample code fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the sample code. In no event should the code be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SAMPLE CODE, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. Although the copyright in the code belongs to Citrix, any distribution of the sample code should include only your own standard copyright attribution, and not that of Citrix. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the sample code.

Resolution

We can sanitize the files affected with the following command:
 
perl -pi -e 's/[^[:ascii:]]//g' <FILENAME>



Example:
 
perl -pi -e 's/[^[:ascii:]]//g' nsvpn.log

Problem Cause

Non-ascii characters located into the file that is about to be opened. If the log file contains non-ascii characters this message can be expected.


For example via more or zmore the characters shows like this:

 

(0-0) process_kernel_socket: call to authenticate user :Kaml;sh Lc)heyur ^Gut<A7>^n J!un, vsid :1199, userlen 29

 

the <A7> is actually Unicode - translates to  \xa. This breaks the GUI and causes the issue.

 

To test and know if the file has the mentioned characters can be tested with this one liner:
 

 perl -ne 'print "$. $_" if m/[\x00-\x08\x0E-\x1F\x80-\xFF]/' <FILENAME>


It will show the line or lines that contains the offending character.

Issue/Introduction

Could not process the file. File size is too large Non-ascii characters present on the log files.