Gateway session time out not working as expected

Gateway session time out not working as expected

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Article ID: CTX322919

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Updated On:

Description

Gateway time session out configured in the session profile doesn't work as expected.

Resolution

Even though the end user does not have any action performed on the client, if there is any network traffic passing through the client and the backend server, then session timeout would extend it by 5 minutes.

Not performing any operation doesn’t mean that there is no network traffic. As per the article - https://docs.citrix.com/en-us/citrix-gateway/current-release/vpn-user-config/configure-plugin-connections/configure-time-out-settings.html for the session time out we have the following 

Session time-out. If you enable this setting, Citrix Gateway disconnects the session if no network activity is detected for the specified interval. This setting is enforced for users who connect with the Citrix Gateway plug-in, Citrix Workspace app, Citrix Secure Hub, or through a web browser. The default timeout setting is 30 minutes. Minimum value is 1, and maximum value is 65535.

If we want to minimize the stale connections, then need to reduce both the sessTimeout and forcedTimeout in the session profile.

Problem Cause

ADC is working s per the design.

Additional Information

https://support.citrix.com/article/CTX201708 - More details on how the Session Timeout works