Launched App Stuck In 1 Monitor When 4 Or More Monitors Are Used

Launched App Stuck In 1 Monitor When 4 Or More Monitors Are Used

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Article ID: CTX322588

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Updated On:

Description

  • When Published Apps are launched through Workspace App and the Endpoint Device is using 4 monitors or more, they always open in the main screen (monitor), and once the Published App is moved to another monitor and is maximized, the Published App goes to the original monitor where it started.
  • Whether less than 4 monitors are used, this misbehavior disappears.

Resolution

  • Let’s install the latest Workspace App on the Endpoint-Device Win10: https://www.citrix.com/downloads/workspace-app/windows/workspace-app-for-windows-latest.html
  • Create a new Citrix Policy “Graphic_PolicySettings” through Citrix Studio.
  • Enable the following Citrix Settings within the new Citrix Policy “Graphic_PolicySettings”:
    • Display Memory Limit > 4194303
    • Dynamic Windows Preview > Enabled
    • Allow Visually Lossless Compression > Enabled
    • Framehawk Display Channel > Enabled
    • HDX Adaptive Transport > Preferred
    • Legacy Graphics Mod > Disabled
    • Maximum Allowed Color Depth > 32 Bits Per Pixel
    • Use Video Codec For Compression > For The Entire Screen
    • Visual Quality > Always Lossless
  • Then, set up this new Citrix Policy “Graphic_PolicySettings” with the Highest Priority to avoid other Policy overwrites it.
  • From the Endpoint Device, let’s go to “C:\Program Files (x86)\Citrix\ICA Client
    • Locate the file “wfica32.exe”, right-click it and choose “Properties > Compatibility > Change High DPI Settings” and check the “Override high DPI scaling behavior” and ensure that the Application option is selected.
  • Finally, go to the Workspace App configuration “Advance Preferences > High DPI” and test using “Yes” and if it fails then. select “Let the operating system scale the resolution” and launch the Published App again and test.

Problem Cause

  • Possible conflict between the current GPU and Citrix Policy/Workspace App configuration used.

Additional Information

All component versions supported by the Product Lifecycle Support per Vendor: