Users unable to relaunch the published applications, error "Citrix workspace will try to reconnect..."

Users unable to relaunch the published applications, error "Citrix workspace will try to reconnect..."

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Article ID: CTX319891

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Updated On:

Description

  • Users get disconnected from their active published app session
  • When attempting to relaunch the same app, they get a popup saying 'Citrix Workspace app will try to reconnect for xxx more minutes. Click Disconnect if you want to stop'

Resolution

Disabling 'Session Reliability' policy in Studio remediates the problem as a work around. The correct solution will be accomplished by doing the following:
  • Enable Session Reliability policy in Studio
  • Disable Keep-alive policy in Studio
  • Configure session reliability on HA failover on the ADCs and do appropriate changes on the ADC’s to allow that traffic.
  • Access the main StoreFront server and validate that the 'Secure Ticket Authority' area for teh Citrix Gateway configuration shows  'Enable Session Reliability' ticked

Problem Cause

Citrix ADC firmware was upgraded from build 11.1 to 12.1. This made Session Reliability and Keep Alive features to crash at the Virtual Apps level, preventing sessions to reconnect

Additional Information

Keep Alive policy settings:
https://docs.citrix.com/en-us/xenapp-and-xendesktop/7-15-ltsr/policies/reference/ica-policy-settings/keep-alive-policy-settings.html

Session reliability policy settings:
https://docs.citrix.com/en-us/xenapp-and-xendesktop/7-15-ltsr/policies/reference/ica-policy-settings/session-reliability-policy-settings.html

Session reliability on Citrix ADC high availability pair:
https://docs.citrix.com/en-us/citrix-adc/current-release/ns-ag-appflow-intro-wrapper-con/session-reliablility-on-citrix-adc-ha-pair.html