Black Screen Flashes On Desktop When Clicking on Elements in Application
book
Article ID: CTX318240
calendar_today
Updated On:
Description
When working with some custom applications, the user may experience a black screen flashing or appearing steadily across their desktop when interacting with controls in a published application.
When tracing the issue with WindowsHistory tool, which can be download from here, we also see windows created with the class name "CompatWindowDesktopReplacement"
Environment
Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.
Resolution
The issue may be avoided by setting following per window class seamless flag. Create any registry hives or keys as needed.
Key:
HKLM\System\CurrentControlSet\Control\Citrix\wfshell\TWI\CompatWindowDesktopReplacement
Value#1:
Name: ClassName
Type: REG_SZ
Data: CompatWindowDesktopReplacement
Value#2:
Name: Type
Type: REG_DWORD
Data: 0x1000 (HEX)
Problem Cause
Certain applications create an invisible full-screen window (with the window class "CompatWindowDesktopReplacement"). A seamless window, in this case a full-screen black window, is created for this window. As the user interacts with the application, the CompatWindowDesktopReplacement seamless window may gain focus and cover the client desktop with a full screen black window.
Additional Resources
Was this article helpful?
thumb_up
Yes
thumb_down
No