NetScaler peer node status UNKNOWN in primary node

NetScaler peer node status UNKNOWN in primary node

book

Article ID: CTX318044

calendar_today

Updated On:

Description

During setup of NetScaler High Avaliability(HA), HA node 1 show status UNKNOWN in primary node.

In NetScaler primary node GUI,

  1. navigate to System > High Availability > Nodes, provide the peer node’s NSIP address in the Remote Node IP Address field and peer node's login credentials,
  2. Click Create. However there's no response.
  3. After a while, secondary node show up in GUI but status "UNKNOWN".
  4. Then, SSH to primary node to run "show ha node" command, got below output
Node ID: 1 IP: 10.107.*.*
Node State: UNKNOWN/DOWN
Master State: UNKNOWN
Fail-Safe Mode: UNKNOWN
INC State: UNKNOWN
Sync State: UNKNOWN
Propagation: UNKNOWN
Enabled Interfaces : UNKNOWN
Disabled Interfaces : UNKNOWN
HA MON ON Interfaces : UNKNOWN
Interfaces on which heartbeats are not seen : UNKNOWN
Interfaces causing Partial Failure: UNKNOWN
SSL Card Status: UNKNOWN

Resolution

1: Reset RPC node password in both NetScaler nodes referring To change an RPC node password
2: Rebuild NetScaler HA referring Configuring high availability


 

Problem Cause

NetScaler RPC node password is inconsistent in two nodes.