CWA HTML5 | Unable to print using Citrix PDF Printer

CWA HTML5 | Unable to print using Citrix PDF Printer

book

Article ID: CTX317949

calendar_today

Updated On:

Description

When trying to print from a published application, the users select the "Citrix PDF Printer" observe the message: "Getting PDF file...." (on the bottom right of the webpage) but do not see the "Continue print dialog" after which the document would open within a new tab.

image.png

Additionally, this behavior is observed after upgrade CWA for html5 2006 to newer versions like 2103

Resolution

Please add the below blob parameter inside the rw_act_insert_csp_nsg rewrite policy ->

add rewrite action rw_act_insert_csp_web insert_http_header Content-Security-Policy "\"default-src \'none\' ; form-action \'none\' ; frame-ancestors \'self\' ; base-url \'self\' ; script-src \'self\' ; style-src \'self\' ; img-src \'self\' *customer's cloud URL data: blob:\""

Problem Cause

Rewrite policies for browser support were causing the issue with printing .
Upon reviewing the HTML5 logs, it was observed that after getting the print command, the print preview was not being generated because of content-security-policy. This security restriction was not allowing the print preview to come up.

Additional Information

https://support.citrix.com/article/CTX233095