Citrix Profile Management error: An error occurred while trying to reset security permissions on the registry hive for user.

Citrix Profile Management error: An error occurred while trying to reset security permissions on the registry hive for user.

book

Article ID: CTX316639

calendar_today

Updated On:

Description

Unable to launch applications due to corrupt default profile

Resolution

Update the permission on template profile
  1. Open Registry Editor and load the NTUSER.DAT stored in the template profile using File / Load Hive.
  2. In the path where you loaded the hive, access Software\Microsoft\SystemCertificates\Root\ProtectedRoots, and dismiss the error message you receive.
  3. Right click ProtectedRoots and choose Permissions, click Advanced > navigate to the Owner tab > change the owner to SYSTEM.
  4. Give local administrator full access.
  5. Give Domain users read.
  6. Unload the default user hive.
  7. Reboot VM.

Problem Cause

Default profile got corrupt and do not have correct permissions