book
Article ID: CTX312240
calendar_today
Updated On:
Description
Citrix Virtual Desktops with Citrix Workspace Environment Management Service agents installed may encounter grey screens on launch.
Resolution
In the event this issue is encountered please use one of the following solutions:
- Machine Creation Services:
- Turn on the Master Image and follow these steps:
- Power on master
- Reboot (this step is mandatory)
- Shutdown
- Push update to VDAs
- Provisioning Services
- Create a new version in the vDisk and follow these steps:
- Power on target device on new version
- Reboot (this step is mandatory)
- Shutdown
- Make new version primary
- Reboot target devices
Problem Cause
WEM Service introduced a new feature (Process Hierarchy Control) and a new registry key, WemHook located at HKLM\Software\Citrix\CtxHook\AppInit_Dlls. Due to the logic built in for tamper protection, CtxUvi will disable itself until a reboot is initiated.