Grey Screen when Launching Citrix Virtual Desktop with Citrix WEM Service Agent.

Grey Screen when Launching Citrix Virtual Desktop with Citrix WEM Service Agent.

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Article ID: CTX312240

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Updated On:

Description

Citrix Virtual Desktops with Citrix Workspace Environment Management Service agents installed may encounter grey screens on launch. 

Resolution

In the event this issue is encountered please use one of the following solutions: 
  • Machine Creation Services:
    • Turn on the Master Image and follow these steps: 
      1. Power on master
      2. Reboot (this step is mandatory)
      3. Shutdown
      4. Push update to VDAs
  • Provisioning Services
    • Create a new version in the vDisk and follow these steps: 
      1. Power on target device on new version
      2. Reboot (this step is mandatory)
      3. Shutdown
      4. Make new version primary
      5. Reboot target devices

Problem Cause

WEM Service introduced a new feature (Process Hierarchy Control) and a new registry key, WemHook located at HKLM\Software\Citrix\CtxHook\AppInit_Dlls.  Due to the logic built in for tamper protection, CtxUvi will disable itself until a reboot is initiated.

Additional Information

Troubleshooting Gray or Black Screen