Cannot complete your request error when using Azure AD saml authentication

Cannot complete your request error when using Azure AD saml authentication

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Article ID: CTX309108

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Updated On:

Description

  • SAML authentication policy for AG has been configured.
  • The IDP is Azure AD.
However, "Can not complete your request error" appeared when using AG SSO Storefront.

Environment

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Resolution

Please refer to the document in below link to configure Netscaler and Storefront: https://www.carlstalhood.com/citrix-federated-authentication-service-saml/#storefrontsamlgateway

Problem Cause

  • In session profile, single sign-on domain is configured.
  • On storefront, "Fully delegate credential validation to NetScaler Gateway" is not ticked.