book
Article ID: CTX309108
calendar_today
Updated On:
Description
- SAML authentication policy for AG has been configured.
- The IDP is Azure AD.
However, "Can not complete your request error" appeared when using AG SSO Storefront.
Environment
Citrix is not responsible for and does not endorse or accept any responsibility for the contents or your use of these third party Web sites. Citrix is providing these links to you only as a convenience, and the inclusion of any link does not imply endorsement by Citrix of the linked Web site. It is your responsibility to take precautions to ensure that whatever Web site you use is free of viruses or other harmful items.
Resolution
Please refer to the document in below link to configure Netscaler and Storefront:
https://www.carlstalhood.com/citrix-federated-authentication-service-saml/#storefrontsamlgateway
Problem Cause
- In session profile, single sign-on domain is configured.
- On storefront, "Fully delegate credential validation to NetScaler Gateway" is not ticked.