Citrix Gateway and StoreFront Error After Upgrade "There are no apps or desktops available to you at this time."

Citrix Gateway and StoreFront Error After Upgrade "There are no apps or desktops available to you at this time."

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Article ID: CTX296779

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Updated On:

Description

Customer had upgraded ADC firmware to 13.0.71.44 from 13.0.58.30 during a change window. Post-upgrade when they authenticate and login to their Citrix Gateway URL and land on StoreFront, they get a blank screen with no applications and desktops being displayed. The issue is seen on all browsers including google chrome which is what they use most.

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Resolution

The issue is worked around as soon as the browser is refreshed once; wherein we can see the published resources back and launch them without any issues.

Generally, post-authentication URL will get redirected StoreWeb directly but here still staying at the logon/logonPoint/index.html page which is at RfWebUI Portal theme page.

By further troubleshooting we have identified issue is with RfWebUi Portal Theme and we fixed the issue by changing it to another than RfWebUi.

Problem Cause

Portal theme was causing issue.