Users Cannot Reconnect to Disconnected Sessions with Session Idle Timers Enabled
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Article ID: CTX296769
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Updated On:
Description
Users will not be able to reconnect to disconnected sessions on Windows Server 2019 using Virtual Delivery Agent versions 1912 and higher after waiting the Idle Session Timer.
- Users will disconnect their sessions, the Idle Session Timer will reach the designated policy value, and then upon reconnection attempt, users will be connected to a new session instead of the existing Disconnected Session.
Resolution
There are two ways of resolving this issue:
- Disable Session Idle Timer Policy
- Disable FastReconnect on the Virtual Delivery Agent via the Registry by adding/creating the below information:
- HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Reconnect]
- "FastReconnect"=dword:00000000
Problem Cause
Windows Server 2019 introduced new Session Idle handling in the Operating System, resulting in behavior that can manipulate even Disconnected sessions.
Citrix FastReconnect will not try to modify Idling Sessions and will only attempt to manage Disconnected Sessions.
By design, Session Idle is a session state that exists in between Active and Disconnected session states:
- Active -> Idle -> Disconnect -> Logging Off
However, in Windows Server 2019, Session Idle is still applying to Disconnected Sessions and therefore FastReconnection will not try to reconnect a user to their 'Disconnected' session. This only applies once the Idle Session Timer Policy has completed.
For instance, if the policy for Idle Session Timer is set to 5 minutes, if a user disconnects their session and waits 5 minutes, they will not be able to reconnect to their session. This has been reported to Microsoft as a bug on Windows Server 2019 and Citrix can only work around this item at this time.
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