Citrix Virtual Apps and Desktops - MS Office processes crashes or gets stuck on close

Citrix Virtual Apps and Desktops - MS Office processes crashes or gets stuck on close

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Article ID: CTX292685

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Updated On:

Description

When users open MS Access within ICA session and create a form (it is one of the objects you can create within Access), save and then close the MSAccess UI, the UI goes away but the process MSAccess.exe remains in task manager consuming resources. The issue is specific to ICA session. The issue is not noticed in RDP or in Console. This problem is seen only when the following policies are applied to the ICA session:

  • Auto keyboard display
  • Remote the combo box
This issue can happen with any of the MS Office suite applications / 3rd party applications. We have seen several manifestations of this issue including

1. 3rd party applications leaking memory in ICA session
2. 3rd party application crash on launching from non-windows workspace app
3. Excel Macro failure within ICA session
4. Outlook search failure within ICA session
5. 3rd party Application hang related to Picashell / Wfshell
6. Picashell / Wfshell consuming high CPU

Environment

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Resolution

Root cause of the issue lies in Microsoft UI Automation framework. Customer to engage Microsoft for further investigation.

Note: For MS Office, This issue is supposed to be fixed in MS Office 16.0.14729.20002 build. 

Problem Cause

Citrix mobile policies make use of the Microsoft UI automation framework. In the ICA session when the policies are applied, MS Office applications such as MS Access, Excel etc which also uses the same framework experience UI related issues mentioned in the Symptom section. You may not reproduce the problem in RDP as the Citrix Mobile policies won't be applied in RDP session. However by using the sample code available from, this can be tested within RDP Session:

https://docs.microsoft.com/en-us/windows/win32/winauto/uiauto-howto-implement-event-handlers#handling-focus-changed-events