Random user session launch is stuck at black screen

Random user session launch is stuck at black screen

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Article ID: CTX291431

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Updated On:

Description

Random sessions exhibit black screen at the session start and doesn't go ahead.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

  1. Create the following registry:
Location: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer
Name: AppReadinessPreShellTimeoutMs
Type: DWORD
Value: 60000
  1. Reboot the VDA
Note:
  • For MCS Machines: Include the registry in the master image and update the machine catalog
  • For PVS Machines: Boot a target in Maintenance/private mode, configure the registry, seal the vDisk, and reboot the PVS targets
  • For Manual Machines: Configure the registry on all the VDAs

Problem Cause

App Readiness service timeout could cause the problem.