Workspace error "Your account cannot be added using this mail address" or "Cannot contact store"

Workspace error "Your account cannot be added using this mail address" or "Cannot contact store"

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Article ID: CTX290022

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Updated On:

Description

  • When attempting to add account with NetScaler Gateway FQDN on Windows Workspace, users encounter below error message:
"Your account cannot be added using this email address."
Or
"Your apps are not available at this time. Please try again in few minutes or contact your help desk with this information: Cannot contact store"
  • While, accessing applications through a web browser from the same Windows client works as expected.
 
  • Network Topo of users accessing applications with NetScaler Gateway: 
Workspace App--(Internet)-->> NAT Firewall>>NetScaler Gateway>>CVAD environment

Resolution

Correct external beacon settings to specify at least two highly available external beacon points that can be resolved from public networks.
  1. Select the Stores node in the left pane of the Citrix StoreFront management console and, in the Actions pane, click Manage Beacons.

  2. Click Add to enter the URL of an external beacon point. To modify a beacon point, select the URL in the External beacons list and click Edit. Select a URL in the list and click Remove to stop using that address as a beacon point.


Problem Cause

Incorrect Store beacon settings in storefront. Both Internal Beacon and external Beacon are customized to DNS unresolvable address. You must specify at least two highly available external beacon points that can be resolved from public networks.

Additional Information

Additional Store beacon settings: https://docs.citrix.com/en-us/storefront/1912-ltsr/integrate-with-citrix-gateway-and-citrix-adc/configure-beacon.html