ADC 13.0 - Error : Please log on. The server met an error. Please try again or contact your administrator
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Article ID: CTX289936
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Updated On:
Description
Error after login to Citrix Gateway: "Please log on The server met an error. Please try again or contact your administrator"
Logging in works fine internally through StoreFront server, but fails when trying to log on through Citrix Gateway. The session policy was noted to be looking for a referer header.
Resolution
1. Verify if the session policy is getting a hit using below command :
nsconmsg -d current -g pol_hits -g pcb_hits
2.Remove &&
REQ.HTTP.HEADER Referer EXISTS from the end of the policy expression, or switch the
&& to
||
NOTE : The rest of the policy should remain intact.3. Click Done
Problem Cause
Upgraded ADC: Incoming HTTP request towards the Citrix Gateway does not have Referer header. Citrix Docs does indicate to include REQ.HTTP.HEADER Referer EXISTS (classic, deprecated policy expression) or HTTP.REQ.HEADER("Referer"
).EXISTS (advanced policy expression), but this was causing issues for this particular customer.
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