Office 365 activation issue with Windows 10 VDI's

Office 365 activation issue with Windows 10 VDI's

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Article ID: CTX289614

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Updated On:

Description

Office 365 showing not licensed in published desktop session for the user. 

Citrix App Layering 2009
Issue seen on images created without App Layering too.
Windows 10 dedicated catalog
VDA version: CVAD 1912 LTSR base version 
Azure backend
MCS provisioning method used 
Profile used: UPM 1912 RTM

Resolution

Solution 1: 
Apply the below registry changes on the VDI:

HKCU\software\microsoft to enable its inheritance (right click -> permissions -> advanced, click ‘Enable inheritance’, click ‘Apply’ and ‘OK’) 

This setting have been identified to fix the Office 365 shared licensing activation.

Solution 2: 
The code fix has already added to LTSR 1912 CU1 & CU2 and later current releases. The issue only exists for profiles that are created by 1912 RTM UPM.

So if we logon a brand new account, there should be no issue for 1912 CU2.
For existing users whose profiles were created using 1912 RTM, we should delete both local profile and userstore profile for problematic accounts and logon again (then those account would be like brand new accounts without profiles) , which will also resolve the issue.


 

Problem Cause

The ALL_APP_PACKAGES privilege has mistakenly took away for subkeys of HKCU\software\microsoft. Since O365 has related registry settings under HKCU\software\microsoft , once we manually enable the inheritance of HKCU\software\microsoft, ALL_APP_PACKAGES  privilege can be inherited correctly to its subkeys, fixing the issue.