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Article ID: CTX289487
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Updated On:
Description
When trying to access the Citrix cloud portal as an administrator you may encounter issues if the account has not been properly onboarded or configured.
Symptoms
- "Unable to process your request" on Citrix Cloud Portal
- Display of FAKE FAKE under orgID after login
- Receiving "Sorry, that link isn't valid." When clicking the link in the invite email
Resolution
Please verify the following items:
- Make sure your browser supports TLS 1.2 and cipher suites configured as Citrix Cloud doesn’t allow communication over TLS 1.0 or TLS 1.1 reference: https://docs.citrix.com/en-us/citrix-cloud/overview/requirements/internet-connectivity-requirements.html#system-requirements
- You have a mycitrix.com account that has no issues logging in
- You have cleared browser cache and cookies or are using an incognito window
- You have completed the account creation process at onboarding.citrix.com
- If you are not the primary admin on the account, make sure you have been invited by the primary admin in order to associate your account with the proper OrgID. You can also re-invite an existing admin to reset the process
- If you are using Azure AD you should be using your AAD credentials to log in, not mycitrix.com
If anything account-related is in an unhealthy state, you can also try resetting your password to rule out improper credentials.
Problem Cause
Citrix Cloud portal can be unreachable due to browser issues, improper account configuration, or other connectivity issues
Additional Information
Please check the services status on https://status.cloud.com/
The Citrix Cloud Health Dashboard provides status updates about significant incidents or scheduled maintenance of our Cloud services per geographical region.