Unable to add Store in Native Workspace/Receiver App from External Machines

Unable to add Store in Native Workspace/Receiver App from External Machines

book

Article ID: CTX284854

calendar_today

Updated On:

Description

  • On adding Store error "Your account cannot be added" or "Could not detect the specific account" appears
  • On Storefront no errors in event viewer
  • Wireshark trace on NetScaler shows, NetScaler sent a request to Storefront server for "/Agservices/Discover",  storefront server returns "500 : Internal Error"

Resolution

1. On Storefront Server, check whether AGServices reflects as a folder instead of application
   
 
2. Right click on “Default Web Site” and click “Add Application”:
 
           
 
3. In the dialog box opened,  select right pool and add physical path. Check “Enabled Preload” check box.
 
4. Run IISRESET

Problem Cause

When Netscaler forwards request to /Agservices/discover, IIS cannot find Agservices/discover as an Application in application pool. Hence returns 500 error