CVAD 1912 - Disconnected sessions not logging off after timeout

CVAD 1912 - Disconnected sessions not logging off after timeout

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Article ID: CTX284703

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Updated On:

Description

  • With the Disconnect timer policy configured it is found that large number of sessions remain in the disconnected state and never logoff even after the timeout value as been reached.
  • No hung processes are identified in the session and the session can be manually logged of from Studio.

Resolution

Disable/Remove shortcut for "Tsdicon.exe" and use one of the below supported methods to log off the ICA session.


-- CDViewer
-- close session window directly
-- connection center
-- command line from client sidhttps://support.citrix.com/article/CTX200337
 
 

Problem Cause

The  state of the session experiencing the issue, had the status = ConsoleDisconnected, whereas the correct status of the sessions should be status = RemoteConsoleDisconnected which triggers the disconnected timer and eventually logs off the machine.

 

We identified the impacted users were using "Tsdiscon.exe" shortcut published on their start menu to disconnect the session. And  from internal repro’s in our test environment we were able to confirm that using “tsdiscon.exe” (Inbuilt process in OS for Remote Desktop Services ) transitions the session to incorrect state i.e. status = ConsoleDisconnected.