Change Storefront to force clients to download a specific Workspace App package

Change Storefront to force clients to download a specific Workspace App package

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Article ID: CTX283904

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Updated On:

Description

When downloading Workspace App from Storefront landing page, it is pulling the most recent version instead of specific desired Workspace App package

Resolution

NOTE: If multiple Storefront servers are in a group, first attempt the change below on only one Storefront server.
            If only one Storefront server is in a group, please ensure a valid backup exists before proceeding.
 

  1. On Storefront server, place desired Workspace App installer in: C:\Program Files\Citrix\Receiver Storefront\Receiver Clients\Windows
  2. Then, navigate to C:\inetpub\wwwroot\Citrix\<Store>Web\web.config
  3. Search for 'pluginassistant'
  4. Edit path to reflect the installer placed in C:\Program Files\Citrix\Receiver Storefront\Receiver Clients\Windows
  5. Reset IIS
  6. Test by navigating to altered Storefront server directly.
  7. If expected results are seen, propagate changes to remaining servers in the server group.



This can also be set in the Storefront Console by using the Source for Receivers / Workspace App option
https://docs.citrix.com/en-us/storefront/2402-ltsr/manage-citrix-receiver-for-web-site/deploy-workspace-app.html


Problem Cause

Storefront defaults the installer to the most recent package available on the web.