Chrome Launches with Error: "Extension might have been corrupted and unable to connect to websocket" with Citrix UPM

Chrome Launches with Error: "Extension might have been corrupted and unable to connect to websocket" with Citrix UPM

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Article ID: CTX283489

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Updated On:

Description

  • Issue occurs after upgrade from 7.15 to 1912 CU1
  • On launching published chrome, chrome://extensions/ throw error:  "'Extension might have been corrupted and unable to connect to websocket
  • Although extensions are loaded on AppData\Local\Google\Chrome\User Data\Default\Extensions immediately at session launch  synchronization on browser takes 1-2 min post launch

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

  1. Make the following modifications to UPM policy:
  • Files to Synchronize:
    • AppData\Local\Google\Chrome\User Data\First Run
    • AppData\Local\Google\Chrome\User Data\Local State
    • AppData\Local\Google\Chrome\User Data\Bookmarks
    • AppData\Local\Google\Chrome\User Data\Favicons
    • AppData\Roaming\Google\Chrome\User Data\History
    • AppData\Roaming\Google\Chrome\User Data\Default\Prefrences
    • AppData\Local\Google\Chrome\User Data\Custom Dictionary.txt
 
  • Folders to Mirror:
    • AppData\Local\Google\Chrome\User Data\Default
 
  • Directories to synchronize:
    • AppData\Local\Google\Chrome\User Data\Default
  1. Disable profile streaming

Problem Cause

Profile streaming feature causing delay in profile load